[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug ld/12320] ld --as-needed links libgcc_s.so.1 unnecessarily on Solar

From: ro at CeBiTec dot Uni-Bielefeld.DE
Subject: [Bug ld/12320] ld --as-needed links libgcc_s.so.1 unnecessarily on Solaris 11
Date: Wed, 16 Feb 2011 17:51:13 +0000


--- Comment #6 from Rainer Orth <ro at CeBiTec dot Uni-Bielefeld.DE> 2011-02-16 
17:51:03 UTC ---
> --- Comment #5 from Alan Modra <amodra at gmail dot com> 2011-02-15 23:54:45 
> UTC ---
> So http://sourceware.org/ml/binutils/2010-03/msg00017.html broke --as-needed.
> I did ask why you wanted to follow the mistakes of the Sun linker..  Are you
> certain that the Solaris ABI requires these symbols to be dynamic?

Yes: every versioned symbol (and this includes the base version) needs
to be in .dynamic.


Configure bugmail: http://sourceware.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]