[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug binutils/23199] Phobos static lib not build properly anymore after

From: thomas.mader at gmail dot com
Subject: [Bug binutils/23199] Phobos static lib not build properly anymore after update to binutils 2.30 on NixOS
Date: Sat, 19 May 2018 09:51:25 +0000


Thomas Mader <thomas.mader at gmail dot com> changed:

           What    |Removed                     |Added
             Status|RESOLVED                    |REOPENED
         Resolution|FIXED                       |---

--- Comment #8 from Thomas Mader <thomas.mader at gmail dot com> ---
(In reply to Alan Modra from comment #6)
> OK, so not a binutils bug causing these bad SHT_GROUP section entries.
> The same nm error is reported for all binutils I tried back to 2.25 (at
> which point I stopped looking).  It is possible that your 2.28 binutils had
> some distro patches that made BFD behave better with these bad object files,
> but my binutils-2_28-branch version does not.

I found the problem.
Nix is stripping the libs and binaries on installation and there seems to be a
bug introduced in binutils 2.30 with strip.
I disabled the striping and everythings worked fine.
You can find the unstripped lib here:

Output of nix-build when stripping:

strip is /nix/store/j75dgadrff2d1fyc4fczmcgqkid2imdx-binutils-2.30/bin/strip
stripping (with command strip and flags -S) in

You are receiving this mail because:
You are on the CC list for the bug.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]