[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: su does not recognized root password

From: Bob Proulx
Subject: Re: su does not recognized root password
Date: Sun, 30 Jan 2005 16:21:12 -0700
User-agent: Mutt/1.5.6+20040907i

Tony Guo wrote:
> after I tried a few commands to change to different
> versions of shells available (sh, csh, ksh, etc.) with

That is an important clue.  I think your problem is there.

> my fedora core 2 installation, and have a few su-ed
> windows open, I suddenly found the su command does not
> work any more, neither was my root password
> recognized.

Is it possible that you changed the shell on your root account to
something that is not /bin/sh?  It might prevent you from being able
to start a shell there.

> Though I was able to get the root password
> reestablished, that password is still not recognized
> by su command, even with a newly created user account.

The 'su' command Switches User _to_ an account not _from_ an account.
The account you come from is not important.  Therefore using a newly
created account will not matter.  It only matters the account you are
trying to switch too.

I am guessing the shell for your root account is something other than
/bin/sh and does not exist on the system.  Looking there would provide
some hint as to the problem.  Also looking in the system for any
errors that are reported would be useful.  On my system the syslog
reports authentication errors to /var/log/auth.log but I don't know
where Fedora writes them.

As a side comment, I highly recommend the use of 'sudo' instead of
'su' for normal system administration tasks.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]