[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: configure problem - not building df - coreutils 5.2.1

From: Charles Notley
Subject: Re: configure problem - not building df - coreutils 5.2.1
Date: Thu, 28 Jul 2005 14:33:31 -0700
User-agent: Mozilla Thunderbird 1.0.2 (Windows/20050317)

I tried hardcoding DF_PROG=df in the Makefiles, but it didn't work. I also tried compiling df by itself: address@hidden src]$ mipsel-unknown-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I../lib -I/opt/crosstool/gcc-3.2.3-glibc-2.2.3/mipsel-unknown-linux-gnu/mipsel-unknown-linux-gnu/lib -g -O2 -MT df.o -MD -MP -MF ".deps/df.Po" -c -o df.o df.c address@hidden src]$ mipsel-unknown-linux-gnu-gcc -g -O2 -o df df.o ../lib/libfetish.a
df.o(.text+0x78c): In function `show_dev':
/home/chn/coreutils-5.2.1/src/df.c:298: undefined reference to `get_fs_usage'
collect2: ld returned 1 exit status

I don't understand what get_fs_usage is. I'm guessing that it relates to the origional code you told me to look at:

# These tests are for df.
  if test $gl_cv_list_mounted_fs = yes && test $gl_cv_fs_space = yes; then

Any suggestions on where I should look to better understand this problem?

Paul Eggert wrote:
Charles Notley <address@hidden> writes:

I set the --host argument because I'm cross-compiling.

If you're cross-compiling, then I'm afraid we assume some expertise
on your part so that you can debug the inevitable glitches.
Please see m4/jm-macros.m4 to get a feel for why "configure"
decided that df wasn't worth building.   Look for DF_PROG.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]