[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tail -c fails (coreutils 5.92)

From: Vincent Lefevre
Subject: Re: tail -c fails (coreutils 5.92)
Date: Wed, 2 Nov 2005 01:58:40 +0100
User-agent: Mutt/1.5.11-vl-20051031

On 2005-11-01 15:15:43 -0800, Paul Eggert wrote:
> With coreutils 5.92, you don't need _POSIX2_VERSION=199209 in your
> environment to use "head -5".  "head -5" now has the traditional
> meaning regardless of _POSIX2_VERSION's value.  This change came about
> becase of clarifications to the standard issued January 2005 by the
> Austin Group.  Please see the NEWS file for details.
> You may still need to set _POSIX2_VERSION=199209 if you are running
> older coreutils versions.

On this point, I don't know what's the best way, as I'm using the
same rc files on different machines, that may have an older version.
I can either use _POSIX2_VERSION=199209 all the time or detect the
coreutils version in my .zshenv file, perhaps by parsing the value
of "$(command true --version)".

Vincent Lefèvre <address@hidden> - Web: <http://www.vinc17.org/>
100% accessible validated (X)HTML - Blog: <http://www.vinc17.org/blog/>
Work: CR INRIA - computer arithmetic / SPACES project at LORIA

reply via email to

[Prev in Thread] Current Thread [Next in Thread]