[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: coreutils-6.2: various runtime problems on Darwin-8.7.0 HFS+ (includ

From: mwoehlke
Subject: Re: coreutils-6.2: various runtime problems on Darwin-8.7.0 HFS+ (including attachment this time)
Date: Tue, 26 Sep 2006 10:40:03 -0500
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20060909 Thunderbird/ Mnenhy/

Jim Meyering wrote:
mwoehlke <address@hidden> wrote:

Jim Meyering wrote:
mwoehlke <address@hidden> wrote:
address@hidden wrote:
[let me see if gmane lets me reply to posts]
gmane works great, it's the only way I read this list (and several
others). :-)

btw, thanks for the mails... I just built coreutils on Darwin also, and
had a good number of 'make check' failures.
I am also noticing that
after making coreutils (and some other packages, I think bash was one),
to remove the directory, I have to 'rm -rf coreutils-5.97' as many as
four times before it fully goes away. Odd that just doing it several
times in succession works, though.
Now, *that* is interesting.
Would you please see if you can reproduce that using an rm binary
built from coreutils-6.2?  I couldn't, when using an hfs partition
on Darwin 8.7.0.  The core of rm was seriously revamped between
coreutils-5.97 and 6.0.
I plan to, as soon as I get a chance. FYI this was on an NFS mount so
there might be some weird interaction with the NFS driver... although
I've built coreutils 5.97 on almost a dozen platforms and Darwin (both
x86 and PowerPC as I recall) is the only OS that's given me problems.

I was unable to reproduce that.  Tried both NFS and hfs.
If you can, please give details asap.  I expect to release
coreutils-6.3 very soon.
It'd be particularly useful to know how many files it removes
at each iteration.

Did you try with 5.97? I haven't tried 6.2 yet (will try to do that soon)... Um, actually, I am probably not going to try until someone can tell me how the *&($ to test the exit code of 'make check' after I've piped it through 'tee' :-) - tips would be most welcome!

Easiest test is on coreutils itself...

$ uname -srvmpio
Darwin 7.9.0 Darwin Kernel Version 7.9.0: Wed Mar 30 20:11:17 PST 2005; root:xnu/xnu-517.12.7.obj~1/RELEASE_PPC Power Macintosh powerpc RackMac3,1 Darwin
$ rm --version
rm (GNU coreutils) 5.97
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software.  You may redistribute copies of it under the terms of
the GNU General Public License <http://www.gnu.org/licenses/gpl.html>.
There is NO WARRANTY, to the extent permitted by law.

Written by Paul Rubin, David MacKenzie, Richard Stallman, and Jim Meyering.
$ ls coreutils-5.97
ls: coreutils-5.97: No such file or directory
$ tar xzf coreutils-5.97.tar.gz
$ find coreutils-5.97/ | wc -l
$ rm -rf coreutils-5.97
rm: cannot remove directory `coreutils-5.97/m4': Directory not empty
rm: cannot remove directory `coreutils-5.97/lib': Directory not empty
$ find coreutils-5.97/ | wc -l
$ rm -rf coreutils-5.97
$ find coreutils-5.97/ | wc -l
find: coreutils-5.97/: No such file or directory

(Again, NFS mount, about 60 GB, 28% used.)

Anything else? I could also post the full list of files left over after the first try...

Download. Untar. Configure. Make. Install. Lather. Rinse. Repeat.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]