[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: coreutils-6.8 - error in expr

From: Vin Shelton
Subject: Re: coreutils-6.8 - error in expr
Date: Tue, 12 Jun 2007 22:30:13 -0400

On 6/12/07, Jim Meyering <address@hidden> wrote:
address@hidden (Bob Proulx) wrote:
> I can't recreate that.  First I tried the current version control head
> and it worked fine with your test case.  So I pulled the prior 6.8
> bundle and compiled it.
>   $ wget ftp://alpha.gnu.org/gnu/coreutils/coreutils-6.8.tar.bz2
>   $ tar xjf coreutils-6.8.tar.bz2
>   $ cd coreutils-6.8
>   $ ./configure
>   $ make
>   $ ./src/expr 20x11-common_process-args : '[[:alnum:]_-]\+$'
>   25
> Could you try compiling a pristine copy of coreutils and seeing if
> that works for you?  If it does not can you report back to the mailing
> list here with the results?  Actually, either way we would like to
> hear the resolution.

If, after the above, you still see the problem, please save a copy of
your config.log file (evidence! to send here).  Then you can probably
work around it by rebuilding with ./configure --with-included-regex
That will ensure that you use the regex code bundled with coreutils,
which may be less buggy than what's in your systems C library.

Yes, I had built the coreutils myself.  I had built the package with
icc, the Intel C Compiler, version 9.1.044.  When I rebuild with gcc,
no problem occurs.

 Vin Shelton

The Journey by Mary Oliver

reply via email to

[Prev in Thread] Current Thread [Next in Thread]