[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Rm performance issue

From: Ken Naim
Subject: RE: Rm performance issue
Date: Wed, 26 Sep 2007 13:19:17 -0400

We are using ext3 on top of LVM on IBM SAN. I don't know the SAN hardware
specifics, although I have been trying to squeeze this info out of the
client for a while. 

As for bad io experiences, our core production system use raw devices for
our databases so we don't have the same issue(s), this is our production
reporting system that gets cloned over nightly. So the process removes all
the existing files and then writes new versions of them from a backup onto a
file system. I have noticed the poor io performance since I came onsite but
the unix team keeps saying everything is fine. This rm issue is causing the
database clone process to exceed its allocated downtime window so I thought
I'd start there.

If anyone can point me to any specific information on tuning ext3 file
system I'd appreciate it. I am googling it now.

Thanks much for the help,

-----Original Message-----
From: Andreas Schwab [mailto:address@hidden 
Sent: Wednesday, September 26, 2007 12:51 PM
To: Philip Rowlands
Cc: Ken Naim; address@hidden; address@hidden
Subject: Re: Rm performance issue

Philip Rowlands <address@hidden> writes:

> unlink shouldn't cause much I/O compared to other read/write
> operations, so I'm surprised you only noticed issues with rm.

Deleting a big file can require quite a bit of block reading, depending
on the filesystem and the fragmentation thereof.


Andreas Schwab, SuSE Labs, address@hidden
SuSE Linux Products GmbH, Maxfeldstraße 5, 90409 Nürnberg, Germany
PGP key fingerprint = 58CA 54C7 6D53 942B 1756  01D3 44D5 214B 8276 4ED5
"And now for something completely different."

reply via email to

[Prev in Thread] Current Thread [Next in Thread]