[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ls: write error: Broken pipe

From: Dan Nicolaescu
Subject: Re: ls: write error: Broken pipe
Date: Fri, 09 Nov 2007 07:02:15 -0800

Jim Meyering <address@hidden> writes:

  > Jim Meyering <address@hidden> wrote:
  > > Dan Nicolaescu <address@hidden> wrote:
  > > ...
  > >>   > Have you tried changing your login shell to bash?
  > >>
  > >> Yeah, changing the login shell to bash works.
  > >> But so does running bash from tcsh and running tcsh from that bash.
  > >
  > > I've tried setting my shell to tcsh (tcsh-6.15-1.fc8)
  > > but still can't get it to fail the way it does for you.
  > > Have you tried moving aside all of your ~/.??* files?
  > > Maybe one of those is causing the trouble.
  > >
  > > If you can reproduce it with an empty home directory,
  > > at least we'll know it something specific to tcsh itself and/or
  > > start-up files it reads from somewhere other than your home dir.
  > >
  > > Are you beginning to see why some people prefer not to use tcsh? :-)
  > Here's a more direct way to test tcsh's sighandler.  Run this:
  >     perl -le 'print $SIG{PIPE}'
  > When I start tcsh from an environment where SIGPIPE is ignored,
  > (which is where you see the troubling behavior) it prints "IGNORE":

I created a new account with /bin/tcsh as a shell, deleted all the dot
files in that new account, logged in on a linux console and run the
perl command above.  It prints IGNORE.

tcsh is: tcsh-6.14-15
perl is: perl-5.8.8-23.fc7

So I have an older version of tcsh than you do.

I looked at the src.rpm for my version of tcsh and it has a patch that
tinkers with signal handling (not with SIGPIPE, but still...). I'll
try to install your version of tcsh tonight, and maybe build my
version without any patches.

  > If you could reproduce the problem by starting tcsh manually,
  > I'd suggest debugging (or just using strace) tcsh to see where
  > it's misbehaving.

What should I look for? 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]