[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: coreutils not installable without extra features???

From: Bob Proulx
Subject: Re: coreutils not installable without extra features???
Date: Wed, 19 Mar 2008 17:24:06 -0600
User-agent: Mutt/1.5.13 (2006-08-11)

Dennis Heuer wrote:
> i tried to install coreutils onto a new partition as part of a plain
> new x86_64 system.

Thanks for the report.  Bug reports and improvement suggestions are
always welcome.  However some of your report wasn't clear enough for
me to understand it.

Are you trying to bootstrap create a "from scratch" build of
everything?  Into a completely empty partition?

> i did this from a fedora8 system because my old one
> is a 32bit system.

Is this from a 32-bit or a 64-bit host system?  If 32-bit I assume you
are trying to cross-compile 64-bit binaries from a 32-bit compiler?
That is certainly possible but rather tedious.  Since 64-bit systems
are readily available it would be easier to bootstrap from a 64-bit
system.  If you are doing something different then please explain.

> however, the fedora8 system is really more than
> feature-complete (including compatibility and deprecated stuff) and all
> the tool packages i installed linked to all of that freeheartedly.

I think you just said that the system has a lot of libraries that you
didn't realize were there and the coreutils ./configure found them and
they were linked into your resulting binaries.  Now the program
binaries that were installed are looking for libraries that don't
exist.  Is that correct?

> other packages, like util-linux, at least allowed for disabling this
> behaviour. coreutils doesn't provide such a --without-extras (or
> similar) option. this said, i now have a problem with all of the
> freshly installed coreutils searching for something (libtinfo,
> libselinux, etc.) when i try to start the plain new system to populate
> it natively. this is a great problem because the new system should be as
> small as possible to make stripping dependencies to the parent system
> as easy as possible.

> please support a 'plain' installation without extra dependencies.

Bootstrapping a port from pristine source to a new architecture is not
something that can be trivially done.  Have you looked at how other
systems such as the Gentoo and Linux-From-Scratch projects do their
bootstrapping?  There will be good insight and learning into how the
process works by studying how others have done ports to new
architectures before.  And since amd64 is pretty well known and
one of the dominant architectures most of the underlying work of the
port has already been done.

The way that I know that new systems have been bootstrapped is to
create a small set required utilities that are needed to build the
next layer of utilities which are needed to build the next level of
utilities and so forth until it is done.  Eventually one gets to the
point where they can build full projects directly but initially that
doesn't work.  A layer of bootstrapping code must be ported first.  It
reads to me that you are trying to jump in at the very end of this
process without having done all of the earlier part of the process.

What is your goal in doing this?  If it is simply a from scratch
system then using one of the other source distributions such as I
already mentioned would be able to provide you with a fully compiled
from source system more easily.  They have already worked through the
bootstrapping problems.  If you simply want an amd64 64-bit system
then using one of the distributions that support it (all of the major
ones do now) then I would simply start with a live-boot from one of
those systems.

If you are simply trying to learn how this works from an academic
standpoint that is great too.  Knowledge is always useful.  But there
really isn't any easy way to support something like this out of the
box.  If you have specific suggestions on how to improve the
environment to make this easier for bootstrappers to new architectures
then please let us know.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]