[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: compiling error

From: Jeph Cowan
Subject: Re: compiling error
Date: Fri, 01 Aug 2008 15:11:59 -0600
User-agent: Thunderbird (Macintosh/20080707)

Hi Ralf.

Thanks for the quick reply. I tried the GNU-make and had the same results:

Making all in man
make[2]: Entering directory `/ptmp/jeph/coreutils-6.12/man'
make[2]: *** No rule to make target `\.x', needed by `\.1'.  Stop.
make[2]: Leaving directory `/ptmp/jeph/coreutils-6.12/man'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/ptmp/jeph/coreutils-6.12'
make: *** [all] Error 2

I have not had time yet to try the suggested work around but a patch would be very helpful. Thanks again for your help.

Best Regards... -jeph

Ralf Wildenhues wrote:
Jeph Cowan <jeph <at> ucar.edu> writes:
Making all in man
        cd .. && make  am--refresh
make: 1254-002 Cannot find a rule to create target \.x from dependencies.
make: 1254-004 The error code from the last command is 1.

Try using GNU make instead of the native one.
The  $(NO_INSTALL_PROGS_DEFAULT:%=%.x)  construct in man/Makefile.am
is GNU make-specific.  It can be worked around for example by computing
the substitution in configure.ac, or by letting configure output another
variable that has a nonempty suffix to give to $(var:suf1=suf2).

I can write a patch if you like.


Bug-coreutils mailing list

jeph Cowan
Supercomputer Systems Group
National Center for Atmospheric Research
1850 Table Mesa Drive
Boulder, CO 80305

reply via email to

[Prev in Thread] Current Thread [Next in Thread]