[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] doc: du - clarify default blocksize in usage/manpage

From: Jim Meyering
Subject: Re: [PATCH] doc: du - clarify default blocksize in usage/manpage
Date: Wed, 09 Sep 2009 16:55:39 +0200

Eric Blake wrote:
> Ondřej Vašík <ovasik <at> redhat.com> writes:
>> Good, point. Added blurb about the environment variables to all of those
>> utilities.
>>        fputs (_("\n\
>> +If none of the environment variables BLOCKSIZE, BLOCK_SIZE or \n\
>> +<COMMAND>_BLOCKSIZE is specified, blocksize defaults to 1024 bytes.\n\
> When I do du --help, I'd rather see this spelled out as DU_BLOCKSIZE, not
>> +(or 512 bytes when POSIXLY_CORRECT environment variable is set)\n\
>> +"), stdout);
> This repetition begs for a helper method in system.h.  It would look better
> like:
> emit_blocksize (program_name);

I agree.
Though please call it something like "emit_blocksize_note"
so it's name doesn't imply it's printing a bare number.

> where emit_blocksize takes care of converting program_name to uppercase in its
> spelling of %s_BLOCKSIZE.
> But at least with this version of the patch, you are adding an entirely new
> string for the translators, rather than modifying an existing one, which means
> you won't be breaking any translations, and we have less reason to exclude it
> from 7.6 if Jim likes the idea.

I do indeed.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]