[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Peformance problem with mv

From: Jim Meyering
Subject: Re: Peformance problem with mv
Date: 14 Mar 2001 16:42:18 +0100
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.0.100

Thanks for the report.
4.0p is more than a year old, but even so, I'd be surprised
to learn that it is copying files instead of using renaming.
If you can show that mv from the latest test release


is copying (rather than using rename) files on the same device,
then please let me know.  To verify what it's doing, you can run

  strace -o log uml/* fs

then look in the `log' file to see if it used rename (as expected)
or read/write (to copy).

If your disk was really full, you may well have run out of space
because the destination directory had to grow but couldn't.

John Summerfield <address@hidden> wrote:
| I have GNU fileutils 4.0p installed on Red Hat Linux 6.2.
| I have some files about 420 Mbytes in size, and I tried to move them from one
| directory to another on the same device.
| The command I used was
|    mv uml/* fs/
| What I expected to happen is logically equivalent to
| ln uml/FILE fs/FILE
| rm uml/FILE
| for each file.
| What mv actually attempted was to copy the files with the result it took ages
| and then ran out of space.
| I eventually got round the problem by shuffling directory names and that
| worked well.
| I'm baffled as to why it attempted what it did, but there is no room for
| doubt: I ran out of disk space.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]