[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Building ghostscript as a shared object on Unix platforms

From: Ramandeep Singh, Noida
Subject: Building ghostscript as a shared object on Unix platforms
Date: Tue, 16 Aug 2005 13:23:18 +0530

I am trying to build ghostscript on Unix platforms (GNU/Linux, AIX,
HPUX, Solaris, Irix). 
I have succeeded in building the executable/binary of ghostscript on
Linux, AIX and Solaris. 
The problem is that i want to build ghostscript as a shared object which
uses dynamic library libgs.so, but i am not able to do so. 
While i was able to build the library (libgs.so) on GNU/Linux using the
makefile (unix-gcc.mak) given in ghostscript-version/src directory, i
faced difficulties while doing the same on AIX and other platforms. 
The help given on the internet stated that to build ghostscript as a
shared object on Unix, you can use unix-gcc.mak, but nothing is given on
how to build ghostscript as a shared object using native compiler. 
I also tried building ghostscript on AIX using gcc, but faced some


I tried to compile ghostscript using both xlc and gcc compilers. In both
cases, the build goes well and produces all the object files under
ghostscript/soobj, but when it creates the links to the ghostscript
library and then compiles the src/dxmainc.c using the "-lgs" option, it
gives an error: "collect2: library libgs not found". 
The problem is that in the sobin folder, 2 links (libgs.so and
libgs.so.8) are created which are pointing to the library
"libgs.so.8.15" which is the main ghostscript library, but the library
"libgs.so.8.15" itself is not created during the build. No other error
is produced during the build. (On, Linux: same build commands creates
the library) 
I am not able to make out, why the build is not producing the
ghostscript library when all the object files have been created. 
Please help me!!! 





reply via email to

[Prev in Thread] Current Thread [Next in Thread]