bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Toolkit scrollbars do not work properly.


From: Eli Zaretskii
Subject: Re: Toolkit scrollbars do not work properly.
Date: Mon, 22 Oct 2001 16:06:16 +0200 (IST)

On 22 Oct 2001, Gerd Moellmann wrote:

> Lute Kamstra <address@hidden> writes:
> 
> > and as far as I know, nothing has changed on my system (i.e. same
> > version of motif).  But I cannot be sure about that since I do not
> > maintain all the software on my system.
> 
> AFAICS, there has been only one change in scroll bar related code
> since 21.0.106, in scroll-bar.el, and I think that change wouldn't
> lead to the effects you describe (and it works with LessTif/Motif here
> on FreeBSD as it did with .106).

I certainly don't see anything like that on the SGI box here, with Xaw3d 
scroll bars.  I've just built a Motif version of Emacs 21.1 on that SGI 
box (also Irix 6.5, with the same version 1.2.4 of Motif), and I cannot 
reproduce the problem there, either.

The function in scroll-bar.el where the change was made 
(scroll-bar-toolkit-scroll) is supposed to be called only when you click 
the mouse inside the scroll bar.  Just to be sure, I instrumented that 
function with Edebug and scrolled the display via the keyboard--and 
verified that this function wasn't entered even once.

So I'm at a loss what could be the problem here.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]