bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cannot open termcap database file


From: NAKAJI Hiroyuki
Subject: Re: Cannot open termcap database file
Date: 23 Oct 2001 23:33:51 +0900
User-agent: T-gnus/6.15.3 (based on Oort Gnus v0.03) (revision 06) SEMI/1.14.3 (Ushinoya) FLIM/1.14.3 (Unebigoryƍmae) APEL/10.3 Emacs/20.7 (i386--freebsd) MULE/4.0 (HANANOEN)

>>>>> In <address@hidden> 
>>>>>   address@hidden (Gerd Moellmann) wrote:

 > First, 'make all' failed because the linker option '-z nocombreloc' is
 > not available. I removed it and compilation is done.

GM> I think that has been resolved in the meantime.  Please see another
GM> thread in bug-gnu-emacs.

I'll check gnu.emacs.bug.

 > occurs because my Debian does not have /etc/termcap.

GM> Is Debian/PPC using terminfo instead of termcap?

I'm not sure, but the answer may be YES. Because I can find that

o kterm, less, vi and emacs-20.7 are works good. They are pre-compiled
  packages included in Debian/PPC distribution. They are related to
  termcap or terminfo, aren't they?
o There is no /etc/termcap or any package whose name is including
  'termcap'.
o There is a directory named /etc/terminfo which contains k/kterm etc.
o 'locate termcap' shows:
        /home/nakaji/cvs/emacs20/etc/termcap.src,v
        /home/nakaji/cvs/emacs20/src/termcap.c,v
        /home/nakaji/work/emacs21/src/termcap.o
        /usr/cache/man/cat5/termcap.5.gz
        /usr/lib/perl5/5.005/termcap.pl
        /usr/share/emacs/20.7/etc/termcap.src
        /usr/share/man/man5/termcap.5.gz
o For i386, there is a package named 'termcap-compat'.

Oh, I found the FAQ at
http://www.debian.org/doc/manuals/debian-faq/ch-compat.html

<QUOTE>
3.10 Why can't I compile programs that require libtermcap? 

Debian uses the terminfo database and the ncurses library of terminal
interface routes, rather than the termcap database and the termcap
library. Users who are compiling programs that require some knowledge
of the terminal interface should replace references to libtermcap with
references to libncurses. 

To support binaries that have already been linked with the termcap
library, and for which you do not have the source, Debian provides a
package called termcap-compat. This provides both libtermcap.so.2 and
/etc/termcap. Install this package if the program fails to run with
the error message "can't load library 'libtermcap.so.2'", or complains
about a missing /etc/termcap file.
</QUOTE>
-- 
NAKAJI Hiroyuki



reply via email to

[Prev in Thread] Current Thread [Next in Thread]