bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

replace-string bug using ange-ftp


From: Vladimir Volovich
Subject: replace-string bug using ange-ftp
Date: Wed, 9 Jan 2002 20:53:19 +0300 (MSK)

This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.1.1 (sparc-sun-solaris2.8, X toolkit, Xaw3d scroll bars)
 of 2001-10-22 on video
configured using `configure  --with-xpm --with-jpeg --with-tiff --with-gif 
--with-png'
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: ru_RU.ISO8859-5
  value of $LC_CTYPE: ru_RU.ISO8859-5
  value of $LC_MESSAGES: C
  value of $LC_MONETARY: ru_RU.ISO8859-5
  value of $LC_NUMERIC: ru_RU.ISO8859-5
  value of $LC_TIME: ru_RU.ISO8859-5
  value of $LANG: ru_RU.ISO8859-5
  locale-coding-system: iso-latin-5
  default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

when editing some file opened via ange-ftp, with a CPerl-mode, i
issued command

M-x replace-string RET
2001-12 RET
2002-01 RET

as a result, part of the line of the original file was lost, i.e. the
following lines

============================================================
<td><img width=70 height=250 src="/gif/ad/2001-12/page1.gif"></td>
<td><img width=70 height=250 src="/gif/ad/2001-12/page2.gif"></td>
<td><img width=70 height=250 src="/gif/ad/2001-12/pagesub1.gif"></td>
<td><img width=70 height=250 src="/gif/ad/2001-12/pagesub2.gif"></td>
</tr>
</table></td>

<td><table>
<tr><th>player1</th><td><img width=364 height=60 
src="/gif/ad/2001-12/player1.gif"></td></tr>
<tr><th>player2</th><td><img width=364 height=60 
src="/gif/ad/2001-12/player2.gif"></td></tr>
<tr><th>playersub1</th><td><img width=364 height=60 
src="/gif/ad/2001-12/playersub1.gif"></td></tr>
<tr><th>playersub2</th><td><img width=364 height=60 
src="/gif/ad/2001-12/playersub2.gif"></td></tr>
============================================================

(which were part of the whole buffer) became

============================================================
<td><img width=70 height=250 src="/gif/ad/2002-01></td>
<td><img width=70 height=250 src="/gif/ad/2002-01/page2.gif"></td>
<td><img width=70 height=250 src="/gif/ad/2002-01/pagesub1.gif"></td>
<td><img width=70 height=250 src="/gif/ad/2002-01/pagesub2.gif"></td>
</tr>
</table></td>

<td><table>
<tr><th>player1</th><td><img width=364 height=60 
src="/gif/ad/2002-01/player1.gif"></td></tr>
<tr><th>player2</th><td><img width=364 height=60 
src="/gif/ad/2002-01/player2.gif"></td></tr>
<tr><th>playersub1</th><td><img width=364 height=60 
src="/gif/ad/2002-01/playersub1.gif"></td></tr>
<tr><th>playersub2</th><td><img width=364 height=60 
src="/gif/ad/2002-01/playersub2.gif"></td></tr>
============================================================

(note that /page1.gif" on the first replaced line disappeared).

i'm able to reproduce this reliably: i open the file via ange-ftp, set
cperl-mode, and issue the above command, and get this buggy result.

if i open the file locally (not via ange-ftp), there's no bug.

Recent input:
<S-down> <S-down> <S-down> <S-down> <S-down> <S-down> 
<S-down> <S-down> <S-down> <S-down> <S-down> <C-insert> 
<C-escape> <down> <return> <return> <return> <up> <S-insert> 
<return> <return> <C-escape> <down> <return> <up> <up> 
<up> <up> <up> <up> <up> <up> <up> <up> <up> <up> <up> 
<up> M-x <up> <return> <up> <up> <return> <up> <up> 
<return> <home> <up> <up> <up> <up> <up> <up> <up> 
<up> <up> <up> <up> <S-down> <S-down> <S-down> <S-down> 
<S-down> <S-down> <S-down> <S-down> <S-down> <S-down> 
<S-down> <S-down> <C-insert> <C-escape> <down> <return> 
<return> <S-insert> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <menu-bar> <help-menu> <re
port-emacs-bug>

Recent messages:
Mark set
<<< Press Return to bury the buffer list >>>

Mark set
Replaced 8 occurrences
Mark set
<<< Press Return to bury the buffer list >>>

Mark set
Loading emacsbug...done



reply via email to

[Prev in Thread] Current Thread [Next in Thread]