bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

set-frame-position fails


From: Nick Patavalis
Subject: set-frame-position fails
Date: Wed, 15 Mar 2006 23:25:10 +0200
User-agent: Mutt/1.5.9i

Hi

>From a gnome-terminal, I start the EMACS editor which opens its main
frame at the position selected by the window manager.

In the scratch-buffer, and say:

  (set-frame-position (selected-frame) 100 100)^J
  (set-frame-position (selected-frame) 10 10)^J
  (set-frame-position (selected-frame) 150 10)^J

The frame always moves to the prescribed position. No problem so far.

Now I grab the emacs window with the mouse from its titlebar and move
it (by any amount, even the tiniest). Then I say again:

  (set-frame-position (selected-frame) 10 10)^J

The frame instantly moves to the prescribed position, and then
*immediately* returns to its *original place*. From then-on any
attempt to set the frame's position using "set-frame-position" fails
in the same manner (frame slings-back instantly after momentarily
moving).

The same behavior manifest in any new frame I open: Until the frame is
moved using the mouse, "set-frame-position" works as expected. After
the frame is moved using the mouse, "set-frame-position" no longer
works: The frame, instead, slings-back to its original location, after
momentarily changing position

I'm using:

  A Debian GNU/Linux i686-based system.

  GNU Emacs 21.4.1 (i386-pc-linux-gnu, X toolkit, Xaw3d scroll bars)
  of 2005-03-17 on trouble, modified by Debian

  metacity 2.8.8

Tanks in advance for any help with this, and many thanks for making
the best editor in the world available to us.

/npat

-- 
Nick Patavalis            address@hidden 
http://npat.efault.net/   GPG key id: 0x499C4C86




reply via email to

[Prev in Thread] Current Thread [Next in Thread]