bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: mac emacs port busted.


From: Daniel Engeler
Subject: Re: mac emacs port busted.
Date: Sat, 27 Oct 2007 14:31:51 -0700
User-agent: G2/1.0

On Oct 17, 10:31 pm, Doug Turner <address@hidden> wrote:
> if there is a better place for this kind of reports, please redirect me.
>
> when buildingemacsfor the mac os x with:
>
> ./configure --with-carbon --without-x
> make bootstrap
>
> the result is:
>
> gcc -I/sw/include -L/sw/lib  -prebind -framework Carbon -framework  
> QuickTime -Xlinker -headerpad -Xlinker 690  -o temacs pre-crt0.o  
> dispnew.o frame.o scroll.o xdisp.o  window.o charset.o coding.o  
> category.o ccl.o cm.o term.o terminal.o xfaces.o  emacs.o keyboard.o  
> macros.o keymap.o sysdep.o buffer.o filelock.o insdel.o marker.o  
> minibuf.o fileio.o dired.o filemode.o cmds.o casetab.o casefiddle.o  
> indent.o search.o regex.o undo.o alloc.o data.o doc.o editfns.o  
> callint.o eval.o floatfns.o fns.o print.o lread.o abbrev.o syntax.o  
> unexmacosx.o bytecode.o process.o callproc.o region-cache.o sound.o  
> atimer.o doprnt.o strftime.o intervals.o textprop.o composite.o  
> md5.o  mac.o macterm.o macfns.o macmenu.o macselect.o fontset.o  
> fringe.o image.o  terminfo.o lastfile.o         -lncurses
> /usr/bin/ld: warning -prebind ignored because  
> MACOSX_DEPLOYMENT_TARGET environment variable greater or equal to 10.4
> /usr/bin/ld: Undefined symbols:_res_9_init
> collect2: ld returned 1 exit status
> make[2]: *** [temacs] Error 1
> make[1]: *** [bootstrap-build] Error 2
> make: *** [bootstrap] Error 2
>
> I believe that we need to ensure that the link includes -lresolv.  I  
> also believe that this is related to or a direct cause of the check  
> in to configure.in:
>
> revision 1.477
> date: 2007-10-17 15:53:01 +0000;  author: cyd;  state: Exp;  lines:  
> +31 -4;  commitid: IJUAzOun4gWWAXBs;
> (HAVE_RES_INIT): Define if res_init() exists.
> (HAVE_LIBRESOLV): Also define if we are using res_init().
>
> No patch; sorry.  Happy to try one if you do not have a mac for  
> testing.  If I get some time, i will put something together and post  
> it here.
>
> Regards,
> Doug Turner

Hi Doug,

I encountered the same problem on Emacs 23.0.50.1 under OS X 10.4.10.
Doing a manual "export LIBS=-lresolv" before "make bootstrap" solved
the problem.

Is there no automatic build on all platforms after each check-in?

Regards,
Daniel




reply via email to

[Prev in Thread] Current Thread [Next in Thread]