[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Info-clone-buffer-hook should be renamed

From: Drew Adams
Subject: RE: Info-clone-buffer-hook should be renamed
Date: Thu, 6 Dec 2007 14:51:45 -0800

> > It is a function, not a variable, so its name should not end in `-hook'.
> Like allout-find-file-hook, calc-graph-kill-hook, ... 
> you mean?


It's OK if the function name says to do something with a hook (e.g. `add-hook', 
`mmm-run-major-mode-hook'), but I don't see it as appropriate for many of those 
you cited. Just one opinion, of course.

BTW, at least the following functions have no doc string, but they should have 

delete-selection-pre-hook, delsel-unload-hook, ediff-xemacs-select-frame-hook, 
Info-clone-buffer-hook, next-error-follow-mode-post-command-hook, 
ps-gnus-article-prepare-hook, ps-info-mode-hook, ps-rmail-mode-hook, 
ps-vm-mode-hook, savehist-minibuffer-hook, vc-default-find-file-hook, 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]