bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#856: marked as done (23.0.60; apropos-command and broken fun aliase


From: Emacs bug Tracking System
Subject: bug#856: marked as done (23.0.60; apropos-command and broken fun aliases)
Date: Mon, 1 Sep 2008 14:55:06 -0700

Your message dated Mon, 01 Sep 2008 17:45:04 -0400
with message-id <address@hidden>
and subject line Re: bug#856: 23.0.60; apropos-command and broken fun aliases
has caused the Emacs bug report #856,
regarding 23.0.60; apropos-command and broken fun aliases
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact address@hidden
immediately.)


-- 
856: http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=856
Emacs Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: 23.0.60; apropos-command and broken fun aliases Date: Mon, 1 Sep 2008 23:15:28 +0200
On my system, the following raises an error when evalled with CVS
emacs -Q:

(apropos-command (quote ("vc")) 1)


Backtrace:

Debugger entered--Lisp error: (void-function vc-previous-version)
  documentation(vc-previous-version t)
  apropos-command(("vc") 1)
  call-interactively(apropos-command nil nil)


There are actually two problems related to this bug:

(1) In vc-hooks.el, there is a definition

(define-obsolete-function-alias
 'vc-previous-version 'vc-previous-revision "23.1"),

but the function `vc-previous-revision' is not defined.

(2) `apropos-command' should handle errors caused by broken function
aliases. Else, cases like (1) make `apropos-command' partly unusable.



In GNU Emacs 23.0.60.2 (i686-pc-linux-gnu, GTK+ Version 2.12.11)
 of 2008-08-29 on green
Windowing system distributor `The X.Org Foundation', version 11.0.10402000



--- End Message ---
--- Begin Message --- Subject: Re: bug#856: 23.0.60; apropos-command and broken fun aliases Date: Mon, 01 Sep 2008 17:45:04 -0400 User-agent: Gnus (www.gnus.org), GNU Emacs (www.gnu.org/software/emacs/)
Michael Heerdegen wrote:

> (1) In vc-hooks.el, there is a definition
>
> (define-obsolete-function-alias
>  'vc-previous-version 'vc-previous-revision "23.1"),
>
> but the function `vc-previous-revision' is not defined.

2008-09-01  Glenn Morris  <address@hidden>

            * vc-hooks.el (vc-previous-version): Move alias to vc.el.
            * vc.el (vc-default-previous-version): Move alias here
            * from vc-hooks, and fix name typos.  (Bug#856)


--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]