bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#1335: Arch-dependant data should not be installed in the app bundle


From: Yavor Doganov
Subject: bug#1335: Arch-dependant data should not be installed in the app bundle
Date: Wed, 12 Nov 2008 17:12:00 +0200
User-agent: Wanderlust/2.15.6 (Almost Unreal) SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (Goj┼Ź) APEL/10.7 Emacs/22.2 (i486-pc-linux-gnu) MULE/5.0 (SAKAKI)

Package: emacs,ns

I see no reason to install arch-dependent data in the app bundle when
--ns-disable-ns-self-contained is passed.  This only causes trouble
for distributors (who typically build several variants -- GTK+, Lucid,
-nox and now the GNUstep port) which share the same common binaries
(in Debian shipped in the emacsXX-bin-common package).

This also doesn't make sense for mortal users who wish to install both
a GTK+ and GNUstep Emacs under the same prefix; a perfectly valid
scenario.

2008-11-12  Yavor Doganov  <address@hidden>  (tiny change)

        * configure.in: Under NS, set `exec_prefix' and `libexecdir'
        relative to `ns_appbindir' only if Emacs is configured for a
        self-contained app.


Index: configure.in
===================================================================
RCS file: /sources/emacs/emacs/configure.in,v
retrieving revision 1.575
diff -u -u -r1.575 configure.in
--- configure.in        7 Nov 2008 06:56:39 -0000       1.575
+++ configure.in        12 Nov 2008 14:56:06 -0000
@@ -1274,10 +1274,10 @@
   with_xft=no
   with_freetype=no
   # set up packaging dirs
-  exec_prefix=${ns_appbindir}
-  libexecdir=${ns_appbindir}/libexec
   if test "${EN_NS_SELF_CONTAINED}" = yes; then
      prefix=${ns_appresdir}
+     exec_prefix=${ns_appbindir}
+     libexecdir=${ns_appbindir}/libexec
   fi
 fi
 CFLAGS="$tmp_CFLAGS"







reply via email to

[Prev in Thread] Current Thread [Next in Thread]