[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#1358: error when compiling ftfont.c from CVS

From: Glenn Morris
Subject: bug#1358: error when compiling ftfont.c from CVS
Date: Mon, 17 Nov 2008 20:24:17 -0500
User-agent: Gnus (www.gnus.org), GNU Emacs (www.gnu.org/software/emacs/)

reassign 1358 emacs

"Joe Corneli" wrote:

> 2.1.0
> (Which suggests perhaps I should remove the system-pkgconfi package and
> use the fontconfig2-shl?)

Yes, perhaps. fontconfig 2.2.0 or newer should work.

>> What does the configure script output say about fontconfig?
> Two lines:
> checking GTK_LIBS... -L/sw/lib -L/usr/X11R6/lib -lgtk-x11-2.0
> -lgdk-x11-2.0 -lXrandr -lXinerama -lXext -lXcursor -latk-1.0
> -lgdk_pixbuf-2.0 -lpangoxft-1.0 -lXft -lXrender -lpangox-1.0 -lX11
> -lpangoft2-1.0 -lfontconfig -lfreetype -lpango-1.0 -lm -lgobject-2.0
> -lgmodule-2.0 -lglib-2.0 -lintl -liconv
> checking XFT_LIBS... -L/usr/X11R6/lib -lXft -lfreetype -lXrender -lfontconfig

You don't have a line of the form:

checking for fontconfig >= 2.2.0...

just above the XFT_LIBS part?

It should say "no" if pkg-config reports 2.1.0.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]