bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#2185: marked as done (23.0.90; Configure doesn't find librsvg2 on d


From: Emacs bug Tracking System
Subject: bug#2185: marked as done (23.0.90; Configure doesn't find librsvg2 on debian)
Date: Tue, 03 Feb 2009 13:45:03 +0000

Your message dated Tue, 03 Feb 2009 14:36:02 +0100
with message-id <address@hidden>
and subject line Re: bug#2185: 23.0.90; Configure doesn't find librsvg2 on 
debian
has caused the Emacs bug report #2185,
regarding 23.0.90; Configure doesn't find librsvg2 on debian
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact address@hidden
immediately.)


-- 
2185: http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=2185
Emacs Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: 23.0.90; Configure doesn't find librsvg2 on debian Date: Tue, 03 Feb 2009 13:58:33 +0100
The configure script doesn't find the SVG library that is installed on
my Debian system.

I have these files in /usr/lib:
   librsvg-2.so.2 and librsvg-2.so.2.14.4

But there is no pkg-config entry for it, so configure doesn't find it.

This may very well be a problem with the way Debian distributes
librsvg2 - but isn't there some other way configure can check for
the existence of this library?




In GNU Emacs 23.0.90.1 (i686-pc-linux-gnu, GTK+ Version 2.8.20)
 of 2009-02-02 on kfs-lx
Windowing system distributor `The X.Org Foundation', version 11.0.70101000
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: en_DK.UTF-8
  value of $XMODIFIERS: nil
  locale-coding-system: utf-8-unix
  default-enable-multibyte-characters: t

Major mode: Fundamental

Minor modes in effect:
  tooltip-mode: t
  tool-bar-mode: t
  mouse-wheel-mode: t
  menu-bar-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  blink-cursor-mode: t
  global-auto-composition-mode: t
  auto-encryption-mode: t
  auto-compression-mode: t
  line-number-mode: t
  transient-mark-mode: t

Recent input:
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <menu-bar> <help-menu> 
<send-emacs-bug-report>

Recent messages:
or information about GNU Emacs and the GNU system, type C-h C-a.



--- End Message ---
--- Begin Message --- Subject: Re: bug#2185: 23.0.90; Configure doesn't find librsvg2 on debian Date: Tue, 03 Feb 2009 14:36:02 +0100 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.90 (gnu/linux)
On 2009-02-03 13:58 +0100, Kim F. Storm wrote:

> The configure script doesn't find the SVG library that is installed on
> my Debian system.
>
> I have these files in /usr/lib:
>    librsvg-2.so.2 and librsvg-2.so.2.14.4

And apparently missing librsvg-2.so, yes?  That symlink is in the
librsvg2-dev package.

> But there is no pkg-config entry for it, so configure doesn't find it.

The pkg-config entry is in the librsvg2-dev package as well.

> This may very well be a problem with the way Debian distributes
> librsvg2 - but isn't there some other way configure can check for
> the existence of this library?

Without the necessary header files you cannot build applications against
it anyway.

Sven


--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]