bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#2949: 23.0.92; font-info incompatible across Emacs versions


From: Miles Bader
Subject: bug#2949: 23.0.92; font-info incompatible across Emacs versions
Date: Sun, 12 Apr 2009 02:26:01 +0900

"Drew Adams" <address@hidden> writes:
> In Emacs 20, `font-info' returns an array like this:
...
> In Emacs 22 and later, it returns an array like this:
...
> This breaks any code that tries to use the result with different Emacs 
> versions.

So.... what exactly do you want to happen?

The two formats look easy enough to distinguish.  Since the change
occurred in 22, it's been widely released, so obviously 3rd-party code
simply has to be prepared to deal with it (if they care about 21 and
older versions), and there's little point in changing it back now.

-Miles

-- 
Education, n. That which discloses to the wise and disguises from the foolish
their lack of understanding.






reply via email to

[Prev in Thread] Current Thread [Next in Thread]