bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#3362: marked as done (23.0.91; smtpmail and starttls)


From: Emacs bug Tracking System
Subject: bug#3362: marked as done (23.0.91; smtpmail and starttls)
Date: Tue, 02 Jun 2009 20:35:04 +0000

Your message dated Tue, 2 Jun 2009 22:25:45 +0200
with message-id <address@hidden>
and subject line Re: bug#3362: 23.0.91; smtpmail and starttls
has caused the Emacs bug report #3362,
regarding 23.0.91; smtpmail and starttls
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact address@hidden
immediately.)


-- 
3362: http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=3362
Emacs Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: 23.0.91; smtpmail and starttls Date: Sun, 24 May 2009 10:56:48 +0200
I am having difficulties to establish a communication to an smtp
server using smtpmail.el and starttls.el:

The incomplete connection I get is the following

Opening STARTTLS connection to `foo.bar.com:465'...done
220 foo.bar.com ESMTP Postfix
250-foo.bar.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250 8BITMIME
220 Ready to start TLS
STARTTLS negotiation failed: 20 Ready to start TLS
*** Starting TLS handshake
*** Fatal error: Key usage violation in certificate has been detected.
*** Handshake has failed

smtpmail-send-command: Process SMTP not running


My settings are

(setq smtpmail-auth-credentials '(("foo.bar.com" 465 "winkler" nil))
        smtpmail-starttls-credentials  '(("foo.bar.com" 465 nil nil))

I am not sure whether these settings are correct. Smtpmail doesn't
reach a point when it would ask for a password. -- I find the
docstrings of these variables a bit confusing as they do not comply
with the usual conventions for docstrings. Also, it is not clear to
me whether I need both variables. If yes, why are they apparently
redundant? And the default value for smtpmail-starttls-credentials
is confusing, too, as it cannot be used for anything.

What else to say? Using

  (setq smtpmail-debug-info t)

doesn't give any extra information. And I am using

gnutls-cli (GnuTLS) 2.4.1


In GNU Emacs 23.0.91.1 (i686-pc-linux-gnu, GTK+ Version 2.14.4)
 of 2009-03-23 on regnitz
Windowing system distributor `The X.Org Foundation', version 11.0.10502000



--- End Message ---
--- Begin Message --- Subject: Re: bug#3362: 23.0.91; smtpmail and starttls Date: Tue, 2 Jun 2009 22:25:45 +0200
I realized that the problem I reported was really not related with a
bug in emacs, see the thread

http://lists.gnu.org/archive/html/help-gnutls/2009-05/msg00037.html

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]