bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#3570: marked as done (23.0.94; vc-default-revision-granularity missi


From: Emacs bug Tracking System
Subject: bug#3570: marked as done (23.0.94; vc-default-revision-granularity missing argument)
Date: Mon, 15 Jun 2009 21:05:08 +0000

Your message dated Mon, 15 Jun 2009 16:57:30 -0400
with message-id <address@hidden>
and subject line Re: bug#3570: 23.0.94; vc-default-revision-granularity missing 
argument
has caused the Emacs bug report #3570,
regarding 23.0.94; vc-default-revision-granularity missing argument
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact address@hidden
immediately.)


-- 
3570: http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=3570
Emacs Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: 23.0.94; vc-default-revision-granularity missing argument Date: Mon, 15 Jun 2009 12:26:25 +0100 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.94 (gnu/linux)
Package: emacs,vc
Severity: minor

The function vc-default-revision-granularity should accept a backend
argument, but doesn't.  This gives users of outdated third-party VC
backends confusing error messages at times.

To reproduce:
(progn
  (provide 'vc-foo)
  (vc-call-backend 'foo 'revision-granularity))

Expected: (error "Your backend will not work with this version of VC mode.")
Actual result: wrong-number-of-arguments

Regards,
Magnus


--- End Message ---
--- Begin Message --- Subject: Re: bug#3570: 23.0.94; vc-default-revision-granularity missing argument Date: Mon, 15 Jun 2009 16:57:30 -0400 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.94 (gnu/linux)
> The function vc-default-revision-granularity should accept a backend
> argument, but doesn't.  This gives users of outdated third-party VC
> backends confusing error messages at times.

Thanks.  I've simply removed it, since the default error message works
just as well (and better than `wrong arg number' in any case).


        Stefan

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]