bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#1333: marked as done (23.0; Emacs.app does not load ~/.emacs)


From: Emacs bug Tracking System
Subject: bug#1333: marked as done (23.0; Emacs.app does not load ~/.emacs)
Date: Mon, 22 Jun 2009 20:50:04 +0000

Your message dated Mon, 22 Jun 2009 23:42:19 +0300
with message-id <87fxds6lw4.GNU'address@hidden>
and subject line Finally fixed
has caused the Emacs bug report #1333,
regarding 23.0; Emacs.app does not load ~/.emacs
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact address@hidden
immediately.)


-- 
1333: http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=1333
Emacs Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: 23.0; Emacs.app does not load ~/.emacs Date: Wed, 12 Nov 2008 16:54:29 +0200 User-agent: SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (Gojō) APEL/10.7 Emacs/22.2 (i486-pc-linux-gnu) MULE/5.0 (SAKAKI)
Package: emacs,ns

On GNUstep, Emacs.app does not load the user init file.

Probably related, but it also doesn't inherit the environment when run
from a terminal; the value of process-environment right after startup
is "TERM=dumb".  Doing M-x ns-grabenv doesn't help much:

process-environment's value is 
("_=/usr/bin/printenv" "SHLVL=1" "PWD=/home/yavor/src/emacs/src" "TERM=dumb")

(This is when started with -nw, the only difference otherwise is the
confusing "DISPLAY=keel.southway-varna.com".)

`printenv | wc -l' returns 29.

If Emacs was built in a chroot and installed in a system-wide
location, e.g. /usr/lib/GNUstep/System/Applications, then M-x gnus
tries to create /News at the root of the filesystem.  Many commands do
not work, and Emacs becomes useful only after manually setting some
variables with M-x setenv and loading .emacs.

(P.S.: The `23.0;' in the subject line is the figure exactly as
generated by M-x report-emacs-bug.)

In GNU Emacs 23.0.60 (i686-pc-linux-gnu, NS gnustep-gui-0.14.0)
 of 2008-11-12 on keel.southway-varna.com
Windowing system distributor `GNU', version 
103.110.117.115.116.101.112.45.103.117.105.45.48.46.49.52.46.48
configured using `configure  '--with-ns' '--disable-ns-self-contained' 
'--prefix=/home/yavor/tmp''




--- End Message ---
--- Begin Message --- Subject: Finally fixed Date: Mon, 22 Jun 2009 23:42:19 +0300 User-agent: Wanderlust/2.15.5 (Almost Unreal) SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (Gojō) APEL/10.7 Emacs/22.3 (i486-pc-linux-gnu) MULE/5.0 (SAKAKI)
This bug was fixed now that the GNUstep port "CAN_DUMP"; Emacs loads
the init file as well as all the environment variables.

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]