bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#3659: FW: 23.0.95; crash on set-frame-font


From: Kenichi Handa
Subject: bug#3659: FW: 23.0.95; crash on set-frame-font
Date: Thu, 25 Jun 2009 15:16:29 +0900

In article <address@hidden>, Chong Yidong <address@hidden> writes:

> Kenichi Handa <address@hidden> writes:
> > At the moment, no.  But, I'll investigate the code in a
> > hurry.

> Thanks.  Glenn has posted a backtrace in the bug tracker:

> http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=3659

Glenn wrote:

> The May 1 and March 1 sources crash in the same way. The Jan 1 and Feb
> 1 sources don't build.

But Simon wrote:

> I narrowed it down to between 2009-05-21 (ok) and 2009-05-22 (coredump)
> via:

Doesn't it mean that the Glenn's crash of May 1 source is
different from Simon's crash of May 21 source?

Among the differeces of src/ChangeLog shown by Simon, these
seem harmless.

> 2009-05-21  Kenichi Handa  <address@hidden>
>
>       * fontset.c (Qlatin): Don't make it static.
>
> 2009-05-19  Kenichi Handa  <address@hidden>
>
>       * font.c (font_sort_entities): Rename from font_sort_entites.
>       Callers changed.
>
> 2009-05-18  Kenichi Handa  <address@hidden>
>
>       * font.c (font_find_for_lface): Copy SPEC's FONT_TYPE too.

And the rest are changes to xfont.c for x font-backend.
But, Glenn's crash is in the code for xft font-backend here:

#0  0xfd3c8b0c in XftLockFace () from /usr/openwin/lib/libXft.so.2
#1  0x0035acdc in xftfont_open (f=0x6794d8, entity=-2133415224, pixel_size=14)
    at xftfont.c:290

This also suggests that their crashes are the different one.

Could you please try to run Emacs as this?

% emacs --xrm 'Emacs*FontBackend: x'

and

% emacs --xrm 'Emacs*FontBackend: xft'

---
Kenichi Handa
address@hidden





reply via email to

[Prev in Thread] Current Thread [Next in Thread]