bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#3837: marked as done (flyspell-mode in mail-mode doesn't work: messa


From: Emacs bug Tracking System
Subject: bug#3837: marked as done (flyspell-mode in mail-mode doesn't work: message-signature-separator not defined)
Date: Tue, 14 Jul 2009 07:20:04 +0000

Your message dated Tue, 14 Jul 2009 03:14:40 -0400
with message-id <address@hidden>
and subject line Re: bug#3837: flyspell-mode in mail-mode doesn't work: 
message-signature-separator not defined
has caused the Emacs bug report #3837,
regarding flyspell-mode in mail-mode doesn't work: message-signature-separator 
not defined
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact address@hidden
immediately.)


-- 
3837: http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=3837
Emacs Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: flyspell-mode in mail-mode doesn't work: message-signature-separator not defined Date: Mon, 13 Jul 2009 15:58:55 +0100
flyspell-mode fails to work in mail-mode
See https://bugzilla.redhat.com/show_bug.cgi?id=505684
In Fedora 11, I get the error "Error in
post-command-hook: (void-variable message-signature-separator)"
This is with emacs-22.3-11.fc11.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. emacs junk.txt
2. M-x mail-mode
3. M-x flyspell-mode
4. type junk words
5. flyspell doesn't work

Actual results:
flyspell doesn't work

Expected results:
flyspell should work

Additional info:
flyspell works when not in mail-mode

If I put
    (defvar message-signature-separator "^-- *$" "\
    Regexp matching the signature separator.")
in .emacs, it works.
So it looks like message-signature-separator is not defined anywhere.
And a grep of the *.el supports this.


In GNU Emacs 22.3.1 (x86_64-redhat-linux-gnu, GTK+ Version 2.14.7)
 of 2009-02-09 on x86-1.fedora.phx.redhat.com
configured using `configure  '--build=x86_64-redhat-linux-gnu' 
'--host=x86_64-redhat-linux-gnu' '--target=x86_64-redhat-linux-gnu' 
'--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' 
'--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' 
'--includedir=/usr/include' '--libdir=/usr/lib64' '--libexecdir=/usr/libexec' 
'--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' 
'--infodir=/usr/share/info' '--with-x-toolkit=gtk' 
'build_alias=x86_64-redhat-linux-gnu' 'host_alias=x86_64-redhat-linux-gnu' 
'target_alias=x86_64-redhat-linux-gnu' 'CFLAGS=-DMAIL_USE_LOCKF -O2 -g -pipe 
-Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector 
--param=ssp-buffer-size=4 -m64 -mtune=generic''

Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: en_GB.UTF-8
  locale-coding-system: utf-8
  default-enable-multibyte-characters: t

Major mode: Mail

Minor modes in effect:
  flyspell-mode: t
  encoded-kbd-mode: t
  menu-bar-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  font-lock-mode: t
  unify-8859-on-encoding-mode: t
  utf-translate-cjk-mode: t
  auto-compression-mode: t
  line-number-mode: t

Recent input:
ESC x m a i l - m o d e RET ESC x f l y s p e l l - 
m o d e RET s d s a d f SPC s a d f a s d f a s d f 
a s d f SPC a s d f a s d f a s d f SPC a s d f SPC 
C-u DEL DEL DEL DEL DEL DEL DEL DEL DEL DEL DEL DEL 
DEL DEL DEL DEL DEL DEL DEL DEL DEL DEL DEL DEL DEL 
DEL DEL DEL DEL DEL DEL DEL DEL DEL DEL DEL DEL DEL 
DEL ESC x r e p p DEL o r t - e m a c s - b u g RE
T

Recent messages:
("emacs" "-Q" "-rv")
Loading encoded-kb...done
For information about GNU Emacs and the GNU system, type C-h C-a.
Loading sendmail...
Loading regexp-opt...done
Loading sendmail...done
Loading flyspell...done
Starting new Ispell process [default] ...
Error in post-command-hook: (void-variable message-signature-separator)
Loading emacsbug...done



--- End Message ---
--- Begin Message --- Subject: Re: bug#3837: flyspell-mode in mail-mode doesn't work: message-signature-separator not defined Date: Tue, 14 Jul 2009 03:14:40 -0400 User-agent: Gnus (www.gnus.org), GNU Emacs (www.gnu.org/software/emacs/)
This was fixed last year (will be in 23.1).

http://lists.gnu.org/archive/html/emacs-devel/2008-06/msg00945.html

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]