bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#2840: marked as done ([emacs-nxml-mode] C-c C-b doesn't work as expe


From: Emacs bug Tracking System
Subject: bug#2840: marked as done ([emacs-nxml-mode] C-c C-b doesn't work as expected)
Date: Sat, 24 Oct 2009 21:40:09 +0000

Your message dated Sat, 24 Oct 2009 17:33:36 -0400
with message-id <address@hidden>
and subject line Re: [emacs-nxml-mode] C-c C-b doesn't work as expected
has caused the Emacs bug report #2840,
regarding [emacs-nxml-mode] C-c C-b doesn't work as expected
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact address@hidden
immediately.)


-- 
2840: http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=2840
Emacs Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: Re: [emacs-nxml-mode] C-c C-b doesn't work as expected Date: Wed, 01 Apr 2009 15:54:02 +0800 User-agent: Thunderbird 2.0.0.21 (Windows/20090302)
X-Debbugs-Cc: address@hidden

Chaitanya Gupta wrote:
Hi,

I am using GNU Emacs 23.0.92.1 and the nxml-mode which comes with it. C-c C-b (nxml-balanced-close-start-tag-block) doesn't seem to work as expected.

e.g. if my buffer is like this: (-!- indicates the point)

<html xmlns="http://www.w3.org/1999/xhtml";>
   <head-!-
</html>


And I press C-c C-b, I get this

<html xmlns="http://www.w3.org/1999/xhtml";>
   <head>-!-</head>
</html>


instead of what I was expecting:

<html xmlns="http://www.w3.org/1999/xhtml";>
   <head>
     -!-
   </head>
</html>

This appears to be a bug in Emacs. If I run through nxml-balanced-close-start-tag in edebug, then it works as you expected, but if I let nxml-balanced-close-start-tag run without debugging, it acts as if 'inline was specified rather than 'block.




--- End Message ---
--- Begin Message --- Subject: Re: [emacs-nxml-mode] C-c C-b doesn't work as expected Date: Sat, 24 Oct 2009 17:33:36 -0400
> if my buffer is like this: (-!- indicates the point)
>
> <html xmlns="http://www.w3.org/1999/xhtml";>
>    <head-!-
> </html>
>
>
> And I press C-c C-b, I get this
>
> <html xmlns="http://www.w3.org/1999/xhtml";>
>    <head>-!-</head>
> </html>

I have checked a fix into Emacs CVS.  Thanks for the bug report.

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]