bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#5102: marked as done (23.1; doc-view on a buffer not linked to a fil


From: Emacs bug Tracking System
Subject: bug#5102: marked as done (23.1; doc-view on a buffer not linked to a file)
Date: Mon, 07 Dec 2009 19:30:14 +0000

Your message dated Mon, 07 Dec 2009 14:24:36 -0500
with message-id <address@hidden>
and subject line Re: bug#5102: 23.1; doc-view on a buffer not linked to a file
has caused the Emacs bug report #5102,
regarding 23.1; doc-view on a buffer not linked to a file
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact address@hidden
immediately.)


-- 
5102: http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=5102
Emacs Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: 23.1; doc-view on a buffer not linked to a file Date: Wed, 02 Dec 2009 13:17:50 +0100
There is a problem when trying to display postscript code in a ps-mode buffer
if the buffer is not linked to a file.

Starting with emacs -Q,
- open a new buffer, 
- insert in that buffer the content of a postscript file,
- start ps-mode. 
Now if we type C-c C-c to view the postscript, we are prompted whether
we want to save the content of the buffer. If we answer "no", we get the error

Wrong type argument: stringp, nil

Message buffer reports that this was issued by doc-view-mode.

In GNU Emacs 23.1.1 (i486-pc-linux-gnu, GTK+ Version 2.16.5)
 of 2009-09-14 on raven, modified by Debian
Windowing system distributor `The X.Org Foundation', version 11.0.10605000
configured using `configure  '--build=i486-linux-gnu' '--host=i486-linux-gnu' 
'--prefix=/usr' '--sharedstatedir=/var/lib' '--libexecdir=/usr/lib' 
'--localstatedir=/var/lib' '--infodir=/usr/share/info' 
'--mandir=/usr/share/man' '--with-pop=yes' 
'--enable-locallisppath=/etc/emacs23:/etc/emacs:/usr/local/share/emacs/23.1/site-lisp:/usr/local/share/emacs/site-lisp:/usr/share/emacs/23.1/site-lisp:/usr/share/emacs/site-lisp:/usr/share/emacs/23.1/leim'
 '--with-x=yes' '--with-x-toolkit=gtk' '--with-toolkit-scroll-bars' 
'build_alias=i486-linux-gnu' 'host_alias=i486-linux-gnu' 'CFLAGS=-DDEBIAN -g 
-O2' 'LDFLAGS=-g' 'CPPFLAGS=''

Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: fr_FR.UTF-8
  value of $XMODIFIERS: nil
  locale-coding-system: utf-8-unix
  default-enable-multibyte-characters: t

Major mode: Lisp Interaction

Minor modes in effect:
  show-paren-mode: t
  display-time-mode: t
  tooltip-mode: t
  tool-bar-mode: t
  mouse-wheel-mode: t
  menu-bar-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: 1
  font-lock-mode: t
  blink-cursor-mode: t
  global-auto-composition-mode: t
  auto-composition-mode: t
  auto-encryption-mode: t
  auto-compression-mode: t
  temp-buffer-resize-mode: t
  column-number-mode: t
  line-number-mode: t

Recent input:
M-x r e p o r t - b u f <backspace> g <return>

Recent messages:
Loading debian-ispell...
Loading /var/cache/dictionaries-common/emacsen-ispell-default.el (source)...done
Loading debian-ispell...done
Loading /var/cache/dictionaries-common/emacsen-ispell-dicts.el (source)...done
Loading /etc/emacs/site-start.d/50dictionaries-common.el (source)...done
Loading /etc/emacs/site-start.d/50festival.el (source)...done
Enriched: decoding document...
Indenting...
For information about GNU Emacs and the GNU system, type C-h C-a.



--- End Message ---
--- Begin Message --- Subject: Re: bug#5102: 23.1; doc-view on a buffer not linked to a file Date: Mon, 07 Dec 2009 14:24:36 -0500 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1.50 (gnu/linux)
>> Witha bit more help.  I've installed the patch below which seems to work
>> for me,
> It works for me too.  I'm not sure if we have to wait Harven's
> confirmation to close this bug because his mails unfortunately
> bounce back.

Indeed,


        Stefan

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]