[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Sun, 27 Jun 2010 07:18:57 -0700
> > "Returns point or mark, whichever is larger."
> How about this (for region-end):
> "Returns point or mark, whichever is larger.
> The returned value is the position of the end of the region
> as an integer."
The end of the region is always a position, so no need to speak of the position
of the end of the region.
We don't really need to say that a number is returned, as opposed to a marker.
"Point" is a position, which is a number (natnump). "Mark" is more ambiguous -
it is sometimes referred to as a marker and sometimes as the position of that
marker. So it's probably good to mention that a number is returned, even if not
really necessary. (We also need not specify what kind of number, since it is a
position, but that doesn't hurt either.)
"Returns the larger of point or mark, as a nonnegative integer."
We can add that the function "raises an error if the mark is not set".