[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#6665: 24.0.50; rgrep does not work on Windows

From: Christoph
Subject: bug#6665: 24.0.50; rgrep does not work on Windows
Date: Sun, 18 Jul 2010 22:00:16 -0600
User-agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20100608 Thunderbird/3.1

On 7/18/2010 11:14 AM, Eli Zaretskii wrote:

rgrep does not work on Windows.

Actually, it does; you just don't like the results ;-)

You know, I saw the title in the bug tracker and wondered if someone would pick on that. ;)

In *scratch* buffer evaluate the following to point to GNU find and grep 
(setq find-program "\"C:/Program Files (x86)/GnuWin32/bin/find.exe\"")
(setq grep-program "\"C:/Program Files (x86)/GnuWin32/bin/grep.exe\"")

Why do you need these?  Doesn't Emacs find them?

No. I usually append the directory of the executables to PATH and set the exec path accordingly in my .emacs. This is more portable than adding it to the path permanently on every computer. The setqs above were just to make it work with `emacs -Q'.

I need GNU find because otherwise Windows find complains about incorrect parameter format (maybe a separate issue?).

If you paste all this long command line to the shell window, does the
program work then?  (You may need to mirror the slashes for that.)

No. I pasted it into cmd.exe and it gives the exact same error.

Also, does the problem go away if you replace "(" with "-(" and ")"
with "-)"?

Same result.

Does the problem go away if you copy the two programs to a directory
whose name does not include blanks and parentheses, and invoke them
from there?

No. The spaces are not the problem. I enclosed the path in quotes so it finds the correct executable at this path (I omitted the quotes before and it would only find C:\Program).


reply via email to

[Prev in Thread] Current Thread [Next in Thread]