bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#6781: emacs server with X11 build on OSX


From: Juanma Barranquero
Subject: bug#6781: emacs server with X11 build on OSX
Date: Tue, 3 Aug 2010 04:47:57 +0200

On Tue, Aug 3, 2010 at 04:12, Ken Raeburn <address@hidden> wrote:

> Using ":host 'local" causes the C code to look up the name "localhost",
> which may or may not map to IPv4 and/or IPv6 addresses.  (Almost
> always an IPv4 address of 127.0.0.1; sometimes IPv6 also, and I've
> occasionally seen it mapped to the local ethernet interface's IPv4
> address.)  Not specifying the host at all causes a wildcard address to
> be used, which would be reachable from other hosts, whereas
> 127.0.0.1 generally is not.

[Ah, the wonders of TCP.]

I think you're right, because in Leo's examples it works when he
specifically sets "127.0.0.1", so it's clear that Emacs isn't
selecting that address with "localhost" or 'local. I suppose the Right
Thing to do for server.el is to force it to use "127.0.0.1" instead of
'local for the :host argument.

    Juanma


=== modified file 'lisp/server.el'
--- lisp/server.el      2010-01-13 08:35:10 +0000
+++ lisp/server.el      2010-08-03 02:44:17 +0000
@@ -561,7 +561,7 @@
                       ;; The other args depend on the kind of socket used.
                       (if server-use-tcp
-                          (list :family nil
+                          (list :family 'ipv4
                                 :service t
-                                :host (or server-host 'local)
+                                :host (or server-host "127.0.0.1") ;; bug#6781
                                 :plist '(:authenticated nil))
                         (list :family 'local





reply via email to

[Prev in Thread] Current Thread [Next in Thread]