bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bug#7487: 24.0.50; Gnus nnimap broken


From: Lars Magne Ingebrigtsen
Subject: Re: bug#7487: 24.0.50; Gnus nnimap broken
Date: Sun, 28 Nov 2010 03:56:21 +0100
User-agent: Gnus/5.110011 (No Gnus v0.11) Emacs/24.0.50 (gnu/linux)

Jason Rumney <address@hidden> writes:

> Upon starting Gnus, some of my groups are showing unread articles in the
> summary buffer, including groups which I only manually move articles
> into, and which I have not touched for months. 

[...]

> It seems gnus-agent (which I never explicitly enabled, but have had
> problems with in past upgrades after it was enabled by default) is out
> of sync with the server, and deleting the ~/News/agent directory fixed
> the problem.

Gnus has stopped enabling the Agent by default now, but older
installations can still get in the way.  I've Cc'd this to the Gnus
mailing list -- do any of you know why the Agent got so wildly out of
what with nnimap in the past?

> This is a terrible user experience.  Trying SSL first is a good feature,
> but if it fails, Gnus should fall back to using plain imap as the user
> has configured.  It isn't even obvious to me what variable I have to set
> to access plain imap anymore.

We've discussed the connection methodology on the list in the past, but
it seems I punted on actually implementing this.  I've now changed the
(default) to try imaps first, and if it fails, imap.

If you wish to force a specific protocol, then `nnimap-stream' is the
backend slot to customize.

> Following this, I configured Gnus to use imaps (which I have configured on a
> non-standard port to get through certain firewalls but never bothered to
> use before on localhost), and now run into a third problem.

I don't follow you here.  How did you configure Gnus to use imaps?  And
since that's the default, isn't that what failed?

> Upon logging in, I am prompted to add my login credentials to
> ~/.authinfo.gpg.  This brings up a confusing buffer asking me to mark
> a public key, which I have discovered by trial and error only works if
> I select no public keys so it falls back on symetric encryption.

Yes, that interface is so confusing it's ridiculous.

Ted is rewriting the way Emacs asks for and stores user credentials.
It'll support using the Secrets API in addition to the standard Emacs
.gpg file handling, but the .gpg interface is so wildly user hostile
that I'm tempted to go back to just storing this data in the plain-text
~/.authinfo file until all this has been worked out.

> After entering an encryption password twice, I was able to read my
> mail at last.

Yay!  :-)

> But my problems aren't over yet. When I quit Gnus and start it again,
> my encryption password for authinfo.gpg doesn't appear to work.
> Actually, it is working, because if I enter a different password, it
> fails immediately, whereas if I enter the correct password it loops
> forever asking for my password (maybe not forever, but my patience for
> finding out is limited).

Weird.  Could you

(setq debug-on-quit t)

and then `C-g' when it starts asking you again and again?  Post the
backtrace here.

-- 
(domestic pets only, the antidote for overdose, milk.)
  address@hidden * Lars Magne Ingebrigtsen


reply via email to

[Prev in Thread] Current Thread [Next in Thread]