bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bug#7487: 24.0.50; Gnus nnimap broken


From: Ted Zlatanov
Subject: Re: bug#7487: 24.0.50; Gnus nnimap broken
Date: Mon, 13 Dec 2010 11:08:08 -0600
User-agent: Gnus/5.110011 (No Gnus v0.11) Emacs/24.0.50 (gnu/linux)

On Mon, 13 Dec 2010 04:19:01 +0100 Lars Magne Ingebrigtsen <address@hidden> 
wrote: 

LMI> Stefan Monnier <address@hidden> writes:
>> I think that will only push the problem elsewhere, which is "which file
>> name to use: .authinfo.gpg or .authinfo.spg".  It seems simpler to just
>> let the user configure the behavior she wants.  By default just use
>> symmetric encryption.

LMI> I think that sounds like a good solution.

Hmm, I haven't heard from Daiki Ueno, and he knows EPA/EPG best.  So I'd
like his opinion.  Maybe he agrees the UI is complicated and is planning
something already.

As far as auth-source is concerned, it could have backend initialization
functionality that, when a backend (e.g. a .gpg file) doesn't exist,
will run specific functions, including creating a .gpg file with
symmetric encryption.  But right now it simply lets EPA handle everything.

Ted


reply via email to

[Prev in Thread] Current Thread [Next in Thread]