bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#8162: 23.3; Crash with invalid default-process-coding-system value


From: Chong Yidong
Subject: bug#8162: 23.3; Crash with invalid default-process-coding-system value
Date: Sat, 05 Mar 2011 15:17:38 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.0.50 (gnu/linux)

Kenichi Handa <address@hidden> writes:

> The attached patch (against emacs-23 branch) will fix this
> bug.  Perhaps "XPROCESS (process)->pid = -1" should be done
> much earlier because an error may be signaled before, but,
> I'm not sure.  deactivate_process may not handle such
> situation well.
>
> By the way, as Emacs 23.2 also had this bug, strictly
> speaking, the fix is not for regression.  Should I install
> it for emacs-23 or for emacs-24?

This patch doesn't look at all safe.  At the very least, if it's
included, we'd need another pretest.  But I'm not inclined to include it
for 23.3.  Although it's a crash, (i) both 23.1 and 23.2 have the same
bug, and (ii) the trigger seems quite unusual.

Stefan, WDYT?





reply via email to

[Prev in Thread] Current Thread [Next in Thread]