bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#9909: emacsclient -a "" -s server-name does not start/connect to nam


From: Gregor Zattler
Subject: bug#9909: emacsclient -a "" -s server-name does not start/connect to named server
Date: Sun, 30 Oct 2011 14:57:57 +0100
User-agent: Mutt/1.5.21 (2010-09-15)

Hi emacs developers,

emacsclient -a "" 
starts a new server if there is none before and connects to it.

I would expect that emacsclient -a "" -s my-server-name behaves the
same but starts a server with server-name my-server-name and connects
to this specific emacs server.

But 

emacsclient.emacs-snapshot -a "" -s my-server-name
does not start a server but instead says:
    emacsclient.emacs-snapshot: can't find socket; have you started the
    server?
    To start the server in Emacs, type "M-x server-start".
    Error: Could not start the Emacs daemon

ps (1) shows no emacs server


while 

emacsclient.emacs23 -a "" -s my-server-name 
starts a server but is not able to connect and says at the end of the
output:

    Starting Emacs daemon.
    Emacs daemon should have started, trying to connect again
    emacsclient.emacs23: can't find socket; have you started the server?
    To start the server in Emacs, type "M-x server-start".
    Error: Cannot connect even after starting the Emacs daemon
    
    
ps (1) shows 
    emacs --daemon=????t)????d)??
    


Thank you for developing Emacs, gregor





reply via email to

[Prev in Thread] Current Thread [Next in Thread]