[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#10372: Emacs+Ansi-Term Display Glitches

From: Geoff Ferrari
Subject: bug#10372: Emacs+Ansi-Term Display Glitches
Date: Mon, 26 Dec 2011 15:30:48 +0000
User-agent: Mutt/1.5.21 (2010-09-15)


I'm experiencing some display glitches when using ansi-term to access a
shell under the X11 version of emacs. There seem to be two separate
glitches, and they're a little hard to describe so I've included a link
to a video of the problem.


When I reach a full screen of text under ansi-term (i.e. once I've typed
in a few commands and the history of these commands fills the screen, so
that the input line is now at the bottom of the screen), the whole
screen seems to either flash or jump every time I type a new character.


After I've either filled the screen using my own commands, or after I've
used a programme such as top or mutt which takes over the whole screen,
then the two lines at the top of the screen seem to persist. Running the
"clear" command does not clear them, but they are cleared if I run the
"reset" command.

You can see a download a video (7.6MB) of these glitches from:

Both of these problems occur on both the latest 64-bit versions of ubuntu and
debian wheezy. With the terminal version of emacs I get the second
problem (lines being left at the top of the screen) but not the first
(no display jumpiness).

My version of emacs as reported in Ubuntu 11.10 is

"GNU Emacs 23.3.1 (x86_64-pc-linux-gnu, GTK+ Version 2.24.5)
 of 2011-08-14 on allspice, modified by Debian"

I wonder if there's anything I can do to remove these annoying glitches,
of whether they are a bug that should be reported.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]