[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#10398: [PATCH] Use real vfork under Cygwin: it's fine these days

From: Drew Adams
Subject: bug#10398: [PATCH] Use real vfork under Cygwin: it's fine these days
Date: Wed, 11 Apr 2012 10:48:09 -0700

> I think it's a good change.  And I don't think we should make 
> an effort to support Cygwin versions earlier than 1.7.
> Cygwin 1.5 is no longer supported by Cygwin, so I don't see
> a reason for emacs to try to support it.  I suspect there
> have been many emacs changes that are not compatible with
> Cygwin 1.5.

Dunno what is meant here by "support Cygwin", but FWIW (probably not much) I
still use Cygwin 1.5.  I do so because it seems to work OK for my use cases and
because I have come across lots of problems reported here and there wrt later
versions (and Emacs).

(Yes, I know, you can find whatever problems you want on the Internet, real or
wrong.  Still, why upgrade if I don't need to?)

I do not run Emacs inside Cygwin, but I use Cygwin's `grep' and other commands
from Emacs, and I use Cygwin's bash shell interactively.

I probably won't be upgrading Cygwin anytime soon unless I'm forced to.  But I'm
no doubt not your typical Cygwin user.  Just one data point to consider.  Or

reply via email to

[Prev in Thread] Current Thread [Next in Thread]