[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#11276: minibuffers windows can no longer explictly be resized

From: Drew Adams
Subject: bug#11276: minibuffers windows can no longer explictly be resized
Date: Thu, 19 Apr 2012 08:13:03 -0700

> resize-mini-windows is a misnomer: it actually means "mini-window size
> is controlled by display engine".  That's why window-sizing commands
> in previous versions never paid heed to it, only redisplay did.  And
> that's why, quite counter-intuitively, setting it to _nil_ allows the
> user to resize the mini-window.
> We could make the implementation more in line with the name in future
> versions, if we want, of course.

1. The right way to go is to decide first on the behavior you want.  Then base
the name on what it actually does.  If it needs to be renamed based on the
desired behavior then rename it, deprecating and temporarily aliasing the old

It does not make much sense to instead design the behavior based on what the
name happens to be - unless that behavior is what you want anyway.  IOW, design
and name together; don't constrain the design to an existing name.

2. Wrt naming something that happens automatically (and possibly prevents or
overrides manual change by a user - in this case resizing): Use "auto" or
"automatic".  In this case, call it "autosize", "autoresize",
"automatic-(re)size", or some such.  That suggests that (a) the behavior is
automatic and (b) you might not be able to override it manually.

If the behavior of this option should be to allow automatic resizing (which
might or might not prevent manual resizing, depending on the design), then call
it something like "auto-resize-minibuffer" or "auto-resize-minibuf-window".

3. I've already said before that it is wrong to use only "mini" here.  This is
not just a mini-window, i.e., a small window - it is a minibuffer window.  See
bug #3320, deemed "wont-fix" by Lars:
http://debbugs.gnu.org/cgi/bugreport.cgi?bug=3320.  Perhaps now that others
consider that `resize-mini-windows' is a misnomer (for additional reasons), this
misuse of "mini" can be reconsidered.

4. It might also be wrong (unnecessary for users) to refer here to minibuffer
window_s_ (plural).  In most contexts users do not need to know or care about
the existence of multiple minibuffer windows.  And in this case, unless the
option behavior does something specific that needs to call user attention to
multiple windows, Occam advises to just use the singular in the name.  Nuances,
if need be, can be pointed out in the doc.

5. And in this case it would perhaps not be inappropriate to refer to
auto-resizing of the minibuffer and not bother to add "window".  True, someone
using apropos for "window" would not find it, but a search for "minibuf" would:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]