bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#11603: bug#11637: [PATCH] build: use configure.ac, not configure.in,


From: Stefano Lattarini
Subject: bug#11603: bug#11637: [PATCH] build: use configure.ac, not configure.in, as Autoconf input
Date: Wed, 06 Jun 2012 17:33:47 +0200

[Moving to the correct pre-existing PR]

On 06/06/2012 05:25 PM, Eli Zaretskii wrote:
>> From: Stefano Lattarini <address@hidden>
>> Date: Wed,  6 Jun 2012 13:30:29 +0200
>> Cc: Stefano Lattarini <address@hidden>
>>
>> The Autoconf documentation has been advising for years to prefer
>> 'configure.in' over 'configure.ac', and future version of Autoconf
>> will start issuing runtime warnings if 'configure.in' is still used.
>> See commit 'v2.69-4-g560f16b' of 2012-05-06, "general: deprecate
>> 'configure.in' as autoconf input" in the Autoconf git repository).
> 
> Thanks.  We already have a patch for this,
>
Oops, sorry for not checking before opening a new PR.  Feel free to close
this report when you want.

> see
> 
>   http://debbugs.gnu.org/cgi/bugreport.cgi?bug=11603
> 
> If you have suggestions for the changes there, please follow up at
> that bug report.
>
I'd just suggest adding a reference to the Autoconf git commit that
introduces the new warning:

    See commit 'v2.69-4-g560f16b' of 2012-05-06, "general: deprecate
    'configure.in' as autoconf input" in the Autoconf git repository).

Apart from that, I'm sure Paul has done a good work, as usual :-)

Thanks, and sorry for the noise,
  Stefano





reply via email to

[Prev in Thread] Current Thread [Next in Thread]