bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#15402: 24.3; Emacs and Mac OS Dock bad launch behavior


From: Constantine Vetoshev
Subject: bug#15402: 24.3; Emacs and Mac OS Dock bad launch behavior
Date: Thu, 19 Sep 2013 12:25:07 -0700

On Sep 19, 2013, at 08:54, Jan Djärv <address@hidden> wrote:
> I already checked, LANG is needed to be set properly in the environment, and 
> it isn't when laucnhng from dock.  M-x setenv doesn't help, as it really 
> doesn't setenv anything (should be renamed IMHO).
> 
> So see launchd.conf and launchctl (setenv) on how to add to the environment 
> of programs launched from dock.

Confirmed. That's a really sharp edge, and has symptoms which do not 
necessarily suggest this fix. Is a reasonable workaround possible? Perhaps the 
Mac port can infer a reasonable default value for LANG on startup, based on 
whatever locale information Cocoa provides?

Alternatively, Apple documentation says that using LSEnvironment in Info.plist 
to set an environment variable should help, but using it to set LANG does 
nothing for me.

Also, the real reason I submitted this bug report is bad behavior in term. This 
bad behavior happens to go away with a properly set LANG, but my init.el 
contains all sorts of invocations like:

(set-language-environment "UTF-8")
(prefer-coding-system 'utf-8)
(defadvice multi-term (after cv/multi-term activate)
  (set-buffer-process-coding-system 'utf-8-unix 'utf-8-unix))

This fixes the basic non-ASCII character display problems (I didn't even 
realize Emacs cared that much about LANG), but ansi-term still chokes on long 
lines containing non-ASCII characters — even though it displays them correctly. 
Shouldn't at least one of these settings get term working correctly, even 
without a properly-set LANG?




reply via email to

[Prev in Thread] Current Thread [Next in Thread]