bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#14774: 24.3.50; Warnings from gnutls under Fedora 19


From: Ted Zlatanov
Subject: bug#14774: 24.3.50; Warnings from gnutls under Fedora 19
Date: Mon, 07 Oct 2013 18:16:38 -0400
User-agent: Gnus/5.130008 (Ma Gnus v0.8) Emacs/24.3.50 (gnu/linux)

On Fri, 19 Jul 2013 15:45:53 +0200 Lars Magne Ingebrigtsen <address@hidden> 
wrote: 

LMI> Ted Zlatanov <address@hidden> writes:
>> Aha, I found the problem.  I'm setting the global log function, but not
>> the global "audit log" function which is issuing these.  That function
>> was added in GnuTLS 2.99, after I worked on the GnuTLS integration for
>> Emacs.
>> 
>> I was planning on requiring GnuTLS 3.x anyhow, so perhaps this can be
>> implemented with that rework instead of as a standalone change?

LMI> Sure; if it's likely that that will happen before the next Emacs
LMI> release.  :-)  Which I have no idea when is planned...

Check out this patch, which sets the audit log function correctly if
using GnuTLS 3.x and gives all audit messages level 1.  Does it work for
you?

I will ask separately about requiring GnuTLS 3.x.

Ted

Attachment: gnutlsv3.patch
Description: Text Data


reply via email to

[Prev in Thread] Current Thread [Next in Thread]