bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#15648: 24.2.50; gnutls SSL connection to IMAP server causes emacs to


From: emacs
Subject: bug#15648: 24.2.50; gnutls SSL connection to IMAP server causes emacs to crash completely, bug#15648: 24.2.50; gnutls SSL connection to IMAP server causes emacs to crash completely
Date: Tue, 22 Oct 2013 11:41:09 -0400

address@hidden wrote at about 11:23:59 -0400 on Tuesday, October 22, 2013:
 > Ted Zlatanov wrote at about 09:27:06 -0400 on Tuesday, October 22, 2013:
 >  > On Mon, 21 Oct 2013 15:30:40 -0400 <address@hidden> wrote: 
 >  > 
 >  > > Ted Zlatanov wrote at about 10:22:03 -0400 on Monday, October 21, 2013:
 >  > >> On Fri, 18 Oct 2013 14:29:04 -0400 "" <address@hidden> wrote: 
 >  > >> 
 >  > >> >   Fault Module Name:                 libgnutls-28.dll
 >  > >> ...
 >  > >> > That being said, I downloaded 24.3 from the gnu site and tried it 
 > with
 >  > >> > the latest gnutls-3.0.9  dll's from the suggested
 >  > >> > http://sourceforge.net/projects/ezwinports/files/ site.
 >  > >> 
 >  > >> > And SAME crash of emacs!
 >  > >> 
 >  > >> Could you please try with the latest 3.x from
 >  > >> ftp://ftp.gnutls.org/gcrypt/gnutls/w32/ ?
 >  > >> 
 >  > > Same crash with 3.2.4 as with 3.0.9
 >  > 
 >  > Sorry, I don't know how you can be sure of the library loaded in
 >  > Windows.  Did you put the DLL in the same directory?
 > 
 > The dll's are in a directory that lies within my system PATH.
 > I know they are loaded because (gnutls-available-p) only proves true
 > when I have all the related dll's in the PATH.
 > 
 >  > 
 >  > >> The `gnutls-boot' function is pretty inoffensive so let's make sure the
 >  > >> basics are covered before we dig into the C code.
 >  > 
 >  > Are you able to debug the Emacs executable?  I don't know if the build
 >  > you're using includes the necessary symbols, but a backtrace with at
 >  > least function names would be extremely helpful to figure this out.
 > 
 > I just used edebug... for the trace I submitted...
 >  > 
 >  > Does the problem occur to any server or just the one you listed?  You
 >  > can test with
 >  > 
 >  >  (open-gnutls-stream "tls" "tls-buffer" "imap.gmail.com" "imaps")
 >  > 
 > 
 > This gave the same crash!
 > 
 >  > It's strange that there's been no other reports of this issue.  Do you
 >  > have access to any other systems where you can test?
 > 
 > Could it have anything to do with 64-bit Win7?
 > Could there be any conflicts with cygwin x86_64 that I have installed
 > (though I purposely didn't install cygwin gnutls) -- but could other
 > dll's be in conflict?

OK - I answered my own question.
There seems to be an incompatibility with the cygwin-mount library...






reply via email to

[Prev in Thread] Current Thread [Next in Thread]