bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#20855: Emacs wipes out custom-set-variables while setting package-se


From: Ted Zlatanov
Subject: bug#20855: Emacs wipes out custom-set-variables while setting package-selected-packages for the first time
Date: Wed, 01 Jul 2015 10:49:02 -0400
User-agent: Gnus/5.130012 (Ma Gnus v0.12) Emacs/25.0.50 (gnu/linux)

On Tue, 30 Jun 2015 10:20:47 +0100 Artur Malabarba <address@hidden> wrote: 

AM> 2015-06-30 3:06 GMT+01:00 Ted Zlatanov <address@hidden>:
>> On Sat, 20 Jun 2015 01:11:22 +0000 (UTC) Barry OReilly <address@hidden> 
>> wrote:
>> 
BO> With Emacs master:
BO> commit d213cf0400ee5cad2e7f4626745fd97b942ff5e9   Date:   Thu Jun 18 
19:15:05 2015 -0400
BO> but not Emacs 24.5, I see Emacs wipe out my custom-set-variables when I 
start Emacs, as it sets package-selected-packages for the first time:
>> ...
BO> (NB: I symlink this init.el to .emacs)
BO> These messages don't appear when starting Emacs 24.5.
BO> Also note, my init.el calls package-initialize and package-install 
directly. The writes to init.el occur during a call to (package-install 
'goto-chg), which is not installed.
>> 
>> I just saw this today as well, I hope it's easy to fix.

AM> I just pushed a patch for this. Could you check if that fixes it?

Thanks, Artur.  I think it's fixed for me because I can't replicate it anymore.

Ted





reply via email to

[Prev in Thread] Current Thread [Next in Thread]