bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#20982: 25.0.50; GPG uses GUI dialog box to ask for passphrase


From: Daiki Ueno
Subject: bug#20982: 25.0.50; GPG uses GUI dialog box to ask for passphrase
Date: Mon, 06 Jul 2015 13:43:30 +0900
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.0.50 (gnu/linux)

Richard Stallman <address@hidden> writes:

> Maybe Emacs developers can cooperate with Werner Koch to set up a a
> way GPG and Emacs can work together better for reading the passphrase.
>
> There is the option of using gpg-agent.

We are already working on that, see:
http://debbugs.gnu.org/cgi/bugreport.cgi?bug=20550

and the recent discussions on gnupg-devel mailing list, to make
gpg-agent (and pinentry) respect the INSIDE_EMACS envvar:
https://lists.gnupg.org/pipermail/gnupg-devel/2015-June/029915.html

Now that all patches had landed in both GnuPG (2.1.x) and Emacs (git
master), maybe people who demand on this feature could try it, so it can
be safely backported to the GnuPG stable series?

Regards,
-- 
Daiki Ueno





reply via email to

[Prev in Thread] Current Thread [Next in Thread]