bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#21110: 25.0.50; Images viewed with Image[Imagemagick] mode are garbl


From: Eli Zaretskii
Subject: bug#21110: 25.0.50; Images viewed with Image[Imagemagick] mode are garbled
Date: Thu, 23 Jul 2015 17:57:40 +0300

> Date: Thu, 23 Jul 2015 11:01:20 +0100
> From: Robert Marshall <address@hidden>
> Cc: address@hidden
> 
> I can confirm that building without Cairo stops the corruption

If you can afford one more test, perhaps try building with Cairo, but
without Imagemagick (and with the rest of image support libraries).
The Cairo build makes quite a bit of difference in image.c, but only
one of them is related to the Imagemagick part, so I think it's
important to understand whether this issue with Cairo is specific to
Imagemagick or to images in general.

Does anyone else have problems with Imagemagick (or images in general)
in the Cairo build?

>  > Use "M-x customize-variable RET" to disable all Imagemagick types.
>  >
>  
> I tried this and disabled png support in imagemagick-enabled-types but
> still when I load a png the mode is reported as
> 
> 'Image[imagemagick] mode defined in ‘image-mode.el’'
> 
> which I assume means that it's still using imagemagick?

Probably.  Building without Imagemagick would resolve the mystery.

>  > Btw, please do send a screenshot with the corrupted images, maybe
>  > seeing it will give more ideas.
>  
> Emailed yesterday

Yes, thanks.  Basically, I understand that the "image" shown by Emacs
contains no traces of the image itself, only some random garbage from
some entirely different graphics context, is that right?





reply via email to

[Prev in Thread] Current Thread [Next in Thread]