bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#30672: 26.0.91, Font face lost ?


From: Fabrice Popineau
Subject: bug#30672: 26.0.91, Font face lost ?
Date: Wed, 7 Mar 2018 22:11:44 +0100



2018-03-07 19:08 GMT+01:00 Eli Zaretskii <address@hidden>:
> From: Fabrice Popineau <address@hidden>
> Date: Wed, 7 Mar 2018 15:22:37 +0100
> Cc: address@hidden
>
> Characters are inserted this way :
>
> #(" - apache" 0 1 (face (:family "all-the-icons" :height 2.4) display (raise -0.24) rear-nonsticky t
> font-lock-ignore t))
>
> with the square being \xe909 .
>
> The family is taken into account if I do :
>
> (message #(" - apache" 0 1 (face (:family "all-the-icons" :height 2.4) display (raise -0.24) rear-nonsticky t
> font-lock-ignore t)))
>
> iie the glyph is displayed in the minibuffer, but not if I do
>
> (insert #(" - apache" 0 1 (face (:family "all-the-icons" :height 2.4) display (raise -0.24) rear-nonsticky t
> font-lock-ignore t)))
>
> in the *scratch* buffer.

What if you turn off font-lock-mode in *scratch* -- does this work
then?

Bingo! Yes, this is working.

Moreover, the anwser is as plain as day now.
The parameter 'font-lock-ignore' is meant to be interpreted not by the font-lock package
but by the font-lock+ package !

Somehow, all-the-icons is missing this prerequisite. 
I probably loaded it accidentaly sometime before, reason while I have seen the icons.

Thanks for the help. You can close the bug.

Fabrice

reply via email to

[Prev in Thread] Current Thread [Next in Thread]